Autor Tema: Tutorial de instalación y configuración módulo OVMS  (Leído 28202 veces)

0 Usuarios y 1 Visitante están viendo este tema.

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #15 en: 21 de Marzo de 2014, 09:58:38 »
It's alive !!!

Ayer, aprovechando el día libre, dediqué unas horas para hacer un poco de brico al pitufo para dejar instalado el módulo OVMS de forma definitiva...

- Desmonté la guantera izquierda a la que le hice una pequeña perforación al lado del conector del coche para pasar el cable de data del módulo, dejándolo conectado de una vez y llevé el terminal db9 hacia la otra guantera (dcha) para poder tener el módulo bajo llave.

- Saqué la guantera derecha e hice dos perforaciones, una rectangular para pasar el conector db9 y otra redonda por donde pasar los dos cables de las antenas...

- Siguiendo las sugerencias de instalación de la web de OVMS, saqué el frontal del Twi y fijé allí con adhesivo la antena gps, pasando el cable por los espacios que hay libres hasta la guantera derecha...

- La antena gprs la coloqué en el techo, concretamente en el espacio que hay destinado a los altavoces, por lo que tube que sacar la moldura la cual sale con dos simples tornillos. Más complicado fue pasar el cable por las molduras laterales del parabrisas, pero con un poco de esfuerzo y la ayuda de un improvisado pasa-cables (cable del freno de mi vieja bicicleta) lo logré. Desde allí llevé el conector hasta la guantera derecha y lo conecté al módulo.

- Llegado a este punto, conecté el cable db9 al módulo con lo que se encendieron los leds, primero con el recuento del firmware (2.5.5) seguido de la secuencia de inicialización del módulo. Envié un sms con "STAT?" y a los pocos segundos me llegó la respuesta...

    Not charging
    Full charge: 124 min.
    Range: 50 - 50 km
    SOC: 50,00%  (100,00%..0,00%)
    ODO: 0 km

Posteriormente abrí la app (iPhone) y pude comprobar que todo iba bien, aunque inicialmente el gps me seguía diciendo que me encontraba en Gales, pero esta mañana al rodar con el Twi pude ver que el gps funcionaba correctamente, un poco lento pero por lo menos me decía exactamente donde estaba.

Ahora solo falta actualizar el firmware que lo haré cuando me llegue el Pickit.

Cuando pueda subiré algunas fotos.

Saludos !
Waaaaatts a fons !!!

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #16 en: 21 de Marzo de 2014, 10:53:15 »
Rectifico, la sugerencia de instalación la saqué de la web "Zero Carbon World"

http://zerocarbonworld.org/electric-vehicles/how-to-give-your-renault-twizy-remote-monitoring

Saludos.
Waaaaatts a fons !!!

covarxi

  • Avanzado
  • ***
  • Mensajes: 132
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #17 en: 21 de Marzo de 2014, 12:28:34 »
Ayer compré el módulo en FastTech, así que sigo con mucho interés y expectación vuestros avances y consejos sobre su funcionamiento e instalación.
MUCHAS GRACIAS!!

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #18 en: 21 de Marzo de 2014, 18:48:11 »
Esto se va animando¡¡ ;D, pero yo cada vez estoy mas perdido.....EdtomCat, ¿no tenias problemas de conexión?¿como lo arreglastes?, si le mando una "orden" para que me informe de sus parámetros...(según lo poco que estoy aprendiendo), ORDEN:  MODULE NOMBRE DEL MODULO M SMSIP RT, via sms, me responde "Permission denied" y de ahí no salgo, yo tengo el pick2 y lo he actualizado sin ningún problema a la última versión...pero ni con esas....tengo que estudiar mas :'(, y eso chupa mucho tiempo :P
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

Juanma

  • Novatillo
  • *
  • Mensajes: 31
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #19 en: 22 de Marzo de 2014, 00:00:07 »
Bueno pues uno más que va de conejillo.....voy a realizar el pedido de todo el material pero tengo alguna duda,haber si podéis ayudarme.Para el cable viene que hay dos modelos derecho e izquierdo....cual es que lleváis vosotros.También voy a pillar el  PicKit3 pero no tengo ni idea de compilar,programar ni demás....podrías ayudarme he leído el post una y mil veces pero me quedo igual....la corriente supongo que sale del cable db9. Muchas gracias
« última modificación: 22 de Marzo de 2014, 00:21:36 por Juanma »

covarxi

  • Avanzado
  • ***
  • Mensajes: 132
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #20 en: 22 de Marzo de 2014, 02:05:02 »
Yo he pedido este
http://www.fasttech.com/product/1139300
pensando en el hueco que hay disponible en la guantera, nada más.
Espero no equivocarme.

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #21 en: 22 de Marzo de 2014, 08:41:48 »
Esto se va animando¡¡ ;D, pero yo cada vez estoy mas perdido.....EdtomCat, ¿no tenias problemas de conexión?¿como lo arreglastes?, si le mando una "orden" para que me informe de sus parámetros...(según lo poco que estoy aprendiendo), ORDEN:  MODULE NOMBRE DEL MODULO M SMSIP RT, via sms, me responde "Permission denied" y de ahí no salgo, yo tengo el pick2 y lo he actualizado sin ningún problema a la última versión...pero ni con esas....tengo que estudiar mas :'(, y eso chupa mucho tiempo :P

Que tal Leotron, te aclaro, cuando instalé las antenas por separado todo empezo a funcionar de forma regular, aunque previamente saque la sim y verifiqué que tanto sms com los datos funcionaban correctamente. Por otro lado debes configurar tu movil como el único autorizado para comunicarse con el módulo. Para eso debes enviar un "REGISTER OVMS" sin las comillas, donde "OVMS" es el password inicial que después puedes/debes cambiar por el que tu quieras. El problema de todo es que el manual del Twizy salta toda la parte de configuración inicial, por eso te recomiendo que te bajes el manual del Tesla:.

https://github.com/openvehicles/Open-Vehicle-Monitoring-System/raw/master/docs/OVMS_UserGuide_TeslaRoadster.pdf

Espero encuentres allí todos los detalles que te faltan.

Saludos.
Waaaaatts a fons !!!

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #22 en: 22 de Marzo de 2014, 12:57:45 »
Gracias mil....sobre todo por tu pronta respuesta...que los tiempos son los tiempos....y llegando la primavera.....mas sol y menos sillón, me pondré con tus consejos ;)
 ;D ;D ;D ;D ;D ;D
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #23 en: 22 de Marzo de 2014, 20:01:52 »
Ya funciona¡¡, gracias EdTomCat , era eso, no me había "comunicado conmigomismo ;D, me ha contestado, al comando STAT, pero estoy usando otros y nada como BATT, POWER, y eso...y no me dice ni pio :'(,

La App, me informa me hace falta salir a ver si me localiza el GPS....como dije al principio...¿Quién puede y le apetece crear la tabla y definiciones de los COMANDOS?...yo me pondré pero por el momento sigo pescando mucho el tema...gracias  ;)

Por último...si después de unos parpadeos del STAT en verde (secuencia de 2 parpadeos), y después pasa a parpadear en otra secuencia repetitiva que todavía no he cotando cuantas veces lo hace pero parpadean en código 7 rojos y 5 verdes .....¿que indican?...pues vuelve después a los 2 parpadeos verdes
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #24 en: 22 de Marzo de 2014, 23:39:47 »
Se que es un coñazo Leotron, pero tendrás que leerte todo el manual del Tesla Roadster de pies a cabeza, porque son demasiados parámetros a configurar inicialmente.

Primero que nada tienes que registrarte tu y el Twi como usuario en www.openvehicles.com porque a través del servidor de la web es que se comunica el pitufo.

Los parpadeos del led rojo indican un error de configuración del módulo y recuerdo que siete parpadeos indican problemas de comunicación con el gprs y lo mas probable es que sea por que aun no te has registrado en www.openvehicles.com.

"7 – Error during GPRS initialization"

También tienes que configurar la identidad del modulo a través del comando "MODULE" seguido del la identidad que le has dado a tu coche en la web de OpenVehicles.com, seguido de la unidad de distancia que quieres usar (km o millas) seguido del tipo de notificaciones que quieres usar (sms, app o ambos) seguido del tipo de vehículo (Renault Twizy)

Ejemplo:
MODULE LeoTwi K SMSIP RT

donde:
LeoTwi es el supuesto nombre de tu pitufo
K por Kilometros
SMSIP por que quieres comunicarte por sms y IP (internet/app)
RT por Renault Twizy

En la app tienes que configurar tu vehículo con los datos del registro de OpenVehicles.com, pero también tienes que ir a configuración general de tu móvil (fuera de la app) y configurar otros parámetros...

Son muchas cosas y por eso hay que seguir los pasos uno por uno tanto del manual del Tesla como el del Twizy porque los que te he puesto son los básicos y no estoy muy seguro de que no me haya saltado alguno importante.

Por cierto, para que el gps localice bien el Twi debes rodar un par de kilómetros, incluso menos, porque al principio si no ha rodado seguro que te manda a otra parte del planeta como me pasó a mi...

Después de haber superado el proceso inicial de configuración, y si ya tienes el firmware actualizado podrás empezar a experimentar con los parámetros del motor del Twi.

Por cierto, una vez tengas la configuración final definida te recomiendo que desactives las alertas sms y te comuniques solo por la app porque te darás cuenta que al final del dia te habrá mandado entre 6 y 12 sms dependiendo de las veces que uses el coche y las veces que cargues, que por muy económicos que sean los mensajes pueden llegar a ser un coñazo y volverte loco.

Saludos y Suerte !
Waaaaatts a fons !!!

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #25 en: 23 de Marzo de 2014, 00:46:45 »
Ya me estoy comunicando con él via sms, el tema es que no me funciona la aplicación...como comentastes que hay que tocar otros parámetros fuera de la App(enel móvil te entiendo), pues he creado el servidor de openvehicles, pero la App me pide un PIN....¿que ping?, creo que de los 2 símbolos que se ven en el centro "car" uno es un candando entiendo que tiene que estar en "verde" y el mio esta en "rojo" y con símbolo de abierto...y me pide el Pin ::), muchas gracias compa
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #26 en: 23 de Marzo de 2014, 10:09:55 »
Leotron, la configuración externa de la app (configuración del móvil) debería quedar así...

OVMS SERVER
   Server:  tmc.openvehicles.com
   Port:      6867
   Share Vehicle Color: activo

WWW.OPENVEHICLES.COM
    Username: el que hayas puesto en la web
    Password:  el que hayas puesto en la web

METRICS:
    Temperatures:  Celsius
    Distances:        Kilometers

CHARGE STATIONS:
    Open Charge Map:  activo


En cuanto al pin del candado que mencionas, piensa que la app originalmente estaba diseñada para el Tesla, por lo que los iconos que salen en la pestaña "Car" no está ninguno activo para el Twi (por ahora).

El símbolo rojo del candado es para activar o desactivar los seguros de las puertas, el de la "carita" es para poner el coche en "Valet mode" que el Twi no permite, el "PEM" "MOTOR" y "BATERY" son indicadores de temperatura inactivos para nosotros, el símbolo del sol es para la temperatura ambiente y el "HOMELINK" es para vincular el Twi con la domótica de tu casa, la cual seria configurable si posees una, pero como yo no tengo (por ahora) no se como hacerlo.

Saludos.

Waaaaatts a fons !!!

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #27 en: 23 de Marzo de 2014, 12:04:32 »
No puedo sino dar gracias a tus comentarios....cada vez me lio mas¡¡, es lo de siempre parece que ves la luz.....y se apaga de repente...y mira que me he pegado tiempo con la ayuda del tradugugle.....y todo esto que me cuentas no lo he visto...y te he hecho mucho caso y le he puesto empeño a las instrucciones de TESLA...y la de twizy y yo que se....a parte de tus aclaraciones que ya me despejan los nubarrones y equivocaciones que he entendido...de resto no me funciona correctamente...bueno solo por indicar como es mi situación:

El OVMS, esta con las secuencias de se quedan los led rojo y verde encendidos un ratito y después pasa al aviso del led verde >>>"5 destellos"= " (INICIALIZANDO EL GPRS Red), y por eso supongo que a veces me contesta los SMS y otras veces se queda sin contestarme...creo como dicen los que saben de I+D+i.....uff es que esta nublado y por eso no conecta ....las nubes dificultan las trasmisiones y bla,bla ;D ;D (personalmente siempre me ha hecho gracia)
« última modificación: 23 de Marzo de 2014, 12:17:23 por leotron »
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #28 en: 23 de Marzo de 2014, 16:13:24 »
Buenas sigo r que r y cada vez pesco menos....no encuentro, entiendo ......"Leotron, la configuración externa de la app (configuración del móvil) debería quedar así..." ¿Qué configuración externa o en donde entro para configurarla? es un note II, y ya he dado varios repasos y no encuentro nada que pida estos datos....se que soy muy torpe.....pero aprendo muy rápido  ;)
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #29 en: 23 de Marzo de 2014, 18:51:16 »
esta claro no doy con el servidor :'(
Le envio el comando "GPRS INFO"  y me contesta:
APN:INFO
user:
Password:
GSMorange
GSM/GPRS: Not connected (0x0002AT+CIPSHUT
a mi me aclara y además la App OVMS me informa siempre del error : comprueba los siguientes datos>>>1ºdirreccion server 2º tu ID y PASSWORDS, esta claro EdtomCat, tienes toda la razón pero yo no la encuentro :-[ :-[
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......