Autor Tema: Tutorial de instalación y configuración módulo OVMS  (Leído 28204 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Inram

  • Visitante
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #30 en: 24 de Marzo de 2014, 02:31:04 »
Hola,

Por fin buenas noticias  ;D ;D ;D ;D ;D

Ya tengo mi OVMS volando hacia casa y por otra parte os informo que si sois de movistar  existe una solucion muy buena para lo de las SIM

http://www.movistar.es/particulares/movil/servicios/ficha/res-multisim

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #31 en: 24 de Marzo de 2014, 10:18:30 »
A ver Leotron, por el sms que mostraste veo claro que no has configurado bien los parámetros del gprs... con que compañía tienes la sim ?
Waaaaatts a fons !!!

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #32 en: 24 de Marzo de 2014, 15:54:30 »
Hola Ed, es de orange, pero no me digas que los parametros son SERVIDOR: internet "o orangeworld"
USUARIO: orange PASSWORD: orange.....espero que sea otra cosa.
Ya no se cuantas veces he dado de alta en OVMS, la sim, por recordar y si he metido la gamba....tiene varrios apartados como sabes......de lo que indicastes en otro comentario sobre los parametros:

OVMS SERVER
   Server:  tmc.openvehicles.com
   Port:      6867
   Share Vehicle Color: activo

WWW.OPENVEHICLES.COM
    Username: el que hayas puesto en la web
    Password:  el que hayas puesto en la web

METRICS:
    Temperatures:  Celsius
    Distances:        Kilometers

CHARGE STATIONS:
    Open Charge Map:  activo
Todavia no se donde meterlos, ya que lo mas parecido es uno de los apartados en OVMS, pero no contiene todo estos parametros...seguro que estoy mas perdido que......
Me comunico via SMS, pero la aplicacion me da el error que sabes que es porque no he realizado una buena configuracion o esta omitida en algun sitio. He rebuscado en mi smartphone a ver donde se configura el servidor y encontré en "CUENTAS" una llamada "Servidor" , la abro y y doy de alta con menos parametros ademas como indica "sincronizar" creo que se refiere a cuentas de correo....ya ves me sigo undiendo en la oscuridad ...como será cuando me decida a probar las modificaciones aHHHHyyyuyuuuuyuu, gracias compa ;)
« última modificación: 24 de Marzo de 2014, 16:00:12 por leotron »
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #33 en: 25 de Marzo de 2014, 12:54:53 »
Esos parámetros los encuentras en la configuración del móvil, en el apartado de "Ajustes" si es Android o "Configuración" si es iOS.

De resto ya no se que decirte, solo recomendarte que empieces desde cero según el manual del Tesla Roadster.

Suerte.
Waaaaatts a fons !!!

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #34 en: 25 de Marzo de 2014, 17:53:02 »
Gracias Ed, seguiré tus consejos......y eso que estoy empapándome lo que comentas....

Te comento una cosa que por mi torpeza pueda que este volviendo loco al servidor de ovms, en mi usuario he creado como sabes el "alta de mi buga" y la he borrado...¿sabes si existen tiempos para "actualizar" los datos en el servidor, vamos si es necesario dejar algún tiempo para que "refresque" los datos, ya que estoy sospechando que la cobertura de orange tampoco es muy buena por la zona y esto me ha empujado pensando en malas configuraciones a borrar y dar de alta nuevos "bugas"...y me dice aún borrado el que he dado de alta "que ya existe" y tendría que volver a darle nombres nuevos...que creo que con tu última recomendación....empezaré "radicalmente desde 0"....bueno espero tus comentarios por tu experiencia.....aunque el que nos puso los dientes afilado....no se le ve el pelo ::), seguro que esta disfrutando como un loco.....y no se acuerda de nosotros :'( :'( :'( :'(....socorro ;D ¿a donde estrás mmzo.? Qué envidia sana me das...disfrutando de todo el abanico de posibilidades que te da OVMS...y yo embarrao :-[ o embarrancado :'(
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #35 en: 26 de Marzo de 2014, 09:52:11 »
Yo tuve que borrar el buga y crear uno de nuevo con un nombre diferente porque recuerda que al principio también tuve problemas de gprs, y cuando lo hice, el proceso fue inmediato, ya que enseguida mandé el sms "MODULE" y fue cuando todo empezó a funcionar bien... Recuerda que el nombre que debes mandar en el sms "MODULE" de tu Twizy no es el "Nickname" sino el que pusiste en "Vehicle" y debe ser un nombre compacto, es decir sin espacios...

Espero que este último consejo te sirva de algo !!!
Ojalá vivieras en Barcelona, así podríamos quedar en algún lugar y con mi portátil revisar toda la configuración... tal vez deberías quedar con Marcos !

Suerte !
Waaaaatts a fons !!!

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #36 en: 26 de Marzo de 2014, 14:41:36 »
Buenas...tengo un momentito y no podía dejar de comentar y Ed menos mal que no estoy por Barcelona porque me saldría muy caro el compensarte el tiempo que me has dedicado ::)......es que seguido de tus consejos empece desde "0" pelotero tero...y que comprobé....que las antenas estaban al berres :-[ :-[ :-[, de ahí me venia la sospecha de las coberturas....tenia que estar fuerte la señal para que entrara por la de GPS...bueno estuve dándome yo solito :-\.

Ahora se comunica conmigo por sms fluidamente...pero no me responde a todo los comando que le envió, pero ahora es cuando estoy en pruebas...me falta seguir las siguientes instrucciones del manual pues el meollo lo encontré casi a media-noche y no me daba para mas...hay que currarrr ;).

Una cuestión nueva que ahora me a surgido...la App me identifica ¡por fin!!, y claro aparece el buga con la fotito elegida...pero no presenta ningún dato, me indica unas 38 horas (anoche eran menos claro) en rojo donde esta la antena...entiendo que es la conexión con servidor (me cachis). Si quieres abrirme los ojos un poquito mas pues dime sino sigo como sabes seguiré definiendo el cacharrito.....un saludo y MG ;)
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

mmezo

  • Senior
  • ****
  • Mensajes: 496
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #37 en: 26 de Marzo de 2014, 16:23:09 »
Madre mía, ya no sé cuanto llevo desconectado, pensaba que no era tanto, pero a juzgar por todo lo que ha crecido este hilo parece que ha sido un montón.

Siento no haber podido hacer los tutoriales de configuración a tiempo. :-(

Creo que más o menos ya habéis dado con el tema.

@leotron. Yo hice la cuenta en el servidor de OpenVehicles y registré el vehículo, pero no rellené los datos de conexión de internet en la página para hacer el despliegue automático, sino que envié los comandos de configuración del la red también via SMS. Los datos para orange españa son como has comentado:
apn: internet
usario: orange
contraseña: orange

Se puede mandar el comando "GPRS <apn> <usuario> <clave>" por SMS para configurarlo, así que en tu caso puedes enviar un SMS con:
  GPRS internet orange orange

Para comprobar que se ha guardado puedes mandar un SMS con el contenido:
  GPRS?

y la respuesta debería ser:

GPRS:
APN: internet
User: orange
Password: orange
GPRS:OK
Server: Connected OK

Para que el coche se comunique con el servidor y se puedan registrar los datos y/o utilizar la app, además de tener el GPRS activo hay que darle una "identidad" al módulo. Esto se hace mediante otro SMS:

MODULE <id_vehiculo> <M ó K> <SMS ó IP ó SMSIP> <tipo_vehículo>

Los parámetros son:
id_vehiculo -> el mismo identificador que hayas dado de alta en la página de openvehicles
M ó K -> información en Millas o Kilómetros
SMS ó IP ó SMSIP -> recibir notificaciones por SMS, via datos GSM o por ambas vías
tipo_vehículo -> en nuestro caso "RT" de Renault Twizy.

Por último,  tienes que configurar con qué servidor te quieres comunicar. El SMS para configurar esto es:
SERVER <ip_servidor> <contraseña_vehiculo> < - ó P >

Los parámetros son:
ip_servidor: IP del servidor al que enviar los datos desde el coche. De momento imagino que todo el mundo utilizará el de openvehicles, así que será el 64.111.70.40
contraseña_vehiculo: la que se haya puesto al registrar el vehículo
- ó P: Modo normal (-) o paranóico (P). En modo paranoico se encriptan más datos de forma que ni los propios administradores de la página web los pueden ver, aunque creo que se pierde algo de funcionalidad.

El comando sería por ejemplo:
SERVER 64.111.70.40 miClave33 -

Recordad que esta es la clave del vehículo, aquí (SERVER...) se pone la clave y en el mensaje anterior (MODULE ...) el identificador del vehículo. Esta pareja identificador_vehículo/clave viene a ser como el usuario/contraseña DEL COCHE. No tienen por qué coincidir (y de hecho no debieran) con el usuario y clave para entrar en la página de openvehicles. Estas últimas son para personas (cada uno de nosotros) y las que hay que configurar son las del vehículo.


@EdTomCat, supongo que ya lo habrás encontrado para estas alturas, pero el firmware compilado lo puedes bajar de:
https://github.com/openvehicles/Open-Vehicle-Monitoring-System/tree/master/vehicle/firmware

Hay que elegir la versión RT de "Renault Twizy"  (P.D. no confudir con TR de Tesla Roadster ;-D ). También conviene fijarse en la fecha. Por ejemplo yo lo compilé en su día, porque la fecha del archivo era bastante anterior al lanzamiento de la última versión.

Marcos

P.D. Por si alguien se mete con ello ya, los comandos del twizy para modificar los parámetros hay que ejecutarlos con el coche encendido, al menos con la llave en el primer punto, cuando ya se ilumina el cuadro (no vale que esté iluminado por que está cargando). Cuando recibe y activa el comando suele dar un pitido y en el SMS que te devuelve ya lo advierto, pero hay que apagar el coche y volverlo a encender para que coja las modificaciones. Esto es así al menos para los comandos de cambiar la velocidad máxima, la potencia y el par. Creo que el de modificar la recuperación de carga se puede cambiar "en vivo".


EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #38 en: 26 de Marzo de 2014, 17:23:56 »
Gracias Marcos, se me había olvidado que para descargar el archivo tenia que hacerlo con el botón derecho del mouse, pero la semana pasada revisando todo lo escrito para aconsejar a Leotron lo leí nuevamente y lo descargué... pero aun tengo que esperar por el Pickit que debería llegar esta semana...

Por cierto, que parámetros has tocado hasta ahora ? como va el pitufo ? puedes operar a través de la app ?

Saludos.
Waaaaatts a fons !!!

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #39 en: 26 de Marzo de 2014, 23:50:35 »
NO voy a bombardear esta vez con peroratas extensas....solo una:

¿Se puede estropear el OVMS por haber estado cruzadas las antenas...vamos la GPS en la toma GPRS  y viceversa?...¿se calienta un poco?....y por último (esto porque no he llegado al final del manua :D....¿como se comportan los leds si esta todo correcto?>>>>2 parpadeos verdes secuenciales todo el tiempo¿?, un saludo 8)
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

mmezo

  • Senior
  • ****
  • Mensajes: 496
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #40 en: 27 de Marzo de 2014, 00:36:24 »
@Leotron: Diría que no se puede estropear por cambiar las antenas, otra cosa es que no funcione mientras están mal enchufadas, pero de ahí a estropearse...

Respecto a si se calienta, la verdad es que no lo sé. Lo llevo en la guantera, todo arrebujado (y por cierto no suelo tener problema de cobertura, ni de GPS ni de GPRS) y por tanto ni lo suelo tocar ni ver. Aunque lo cierto es que cuando he ido a sacar algo de allí, o cuando lo he sacado para reprogramarlo o... nunca me he fijado en que estuviera especialmente caliente.

Respecto a los leds, de nuevo ni idea. Leí el manual en su momento, pero se me ha olvidado y como no lo tengo a la vista... (lo siento)

@EdTomCat: Pues yo lo tengo con potencia 120% y par 120% (se puede subir hasta 130%), velocidad máxima 100 (se puede subir hasta 111) y la recuperación si no recuerdo mal la dejé en 16% 20% o algo así. Por defecto creo viene con 18 para ambos valores, pero hablo de memoria. En el manual lo pone. Si se establecen dos valores, el primero lo utiliza para  cuando retiene símplemente por quitar el pie del acelerador y el segundo cuando además estás pisando el freno. De todos modos esta es la recuperación máxima, pero según la velocidad a la que vayas tiene otros parámetros TSMAP N..... y TSMAP B .... (que yo no he tocado) que definen una curva de la que se obtiene un valor que multiplica a la recuperación configurada en función de la velocidad. Esto es para que a velocidades menores recupere más (en %) que a velocidades altas y es así para proteger la batería de cargas excesivas en la recuperación. TSMAP N es para cuando el coche va sin pisar ningún pedal, recuperando pero sin frenar, y la versión B es para cuando estás pisando el freno. Dicen que el sensor que detecta el uso del freno no es demasiado sensible y es posible que haya que pisar con cierta fuerza para que lo detecte.

Por ejemplo a 20km/h el TSMAP B (pisando el freno) es 100% y si el RECUP con freno lo hemos configurado en 20% como en el ejemplo anterior, entonces la recuperación es 100% * 20% es del 20%, sin embargo a alta velocidad, por ejemplo a 70km/h el TSMAP B es del 25% o algo así (en el manual pone todo, yo te hablo de memoria y puede que no sean los valores exactos), en este caso la recuperación sería de  25% * 20%, es decir un 5%. Los porcentajes siempre se refieren a la potencia que tendría el motor en modo conducción o "drive" a esas revoluciones y velocidad según cómo se haya configurado la potencia y el par. Total, que es un poco lioso, y que el propio manual recomienda que en invierno (invierno alemán todo hay que decirlo) nos planteemos incluso bajar la recuperación. Por eso yo la dejé al 16%.

Marcos

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #41 en: 27 de Marzo de 2014, 15:46:10 »
Bueno pues uno más que va de conejillo.....voy a realizar el pedido de todo el material pero tengo alguna duda,haber si podéis ayudarme.Para el cable viene que hay dos modelos derecho e izquierdo....cual es que lleváis vosotros.También voy a pillar el  PicKit3 pero no tengo ni idea de compilar,programar ni demás....podrías ayudarme he leído el post una y mil veces pero me quedo igual....la corriente supongo que sale del cable db9. Muchas gracias
Hola no soy el mas adecuado pues de los que semos en esto creo que voy por el 3º mas avanzado....el ranquin lo lleva mmzo y EdTomCat, que son los que estan mas puestos, pero esto que es algo mas básico te dire si no me rectifican que para el cable que dices...me imagino que te refieres al cable OBDII, que va del módulo al conector del coche...que yo sepa salen dos pero son iguales al mismo precio ¿izquierda y dcha el que? yo no me fije en eso y no lo veo :o.. lo de "no tengo ni idea de.....estamos aqui para hecharnos una mano (al cuello a alguno como yo), pues si has leido este hilo verás que he bombardeado a los compas por mis inquietudes e ignorancias...pero eso sobre todo es por no leeer y traducir.....te aconsejo que te armes de pasiencia y te pongas a leerte el librito de uso y disfrute tanto del Tesla Roadter que es para que en un primer momento se pario y el librito especifico del twizy...como esta en ingles y el traductor es una maravilla para entender ...pues eso paciencia y creo que ninguno somo "especialistas en programar" algunos con mas experiencia que otros...igual mmzo si pero por sus coment da a entender que tampoco por tanto estamos todos igual...unos disfrutando con el juguetito y otros con una ansiedad por no tener el tiempo necesario para esto...un saludo y por aqui esperemos que estemos tooodos ;)
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

leotron

  • Twizero a tope
  • *****
  • Mensajes: 1.043
  • Pequeñito....pero respondon
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #42 en: 28 de Marzo de 2014, 01:11:51 »
mmzo cuando puedas puedes detallar la manera de programar los parámetros...has comentado antes pero creo que un poco por encima...no encuentro en las instrucciones como proceder...y entiendo que tu si lo has conseguido, seria de gran ayuda ;)

Ya tengo todo configurado menos error 5 verde: que inicialización de la red GPRS....y esta siempre intentándolo, tendré que enviar una consulta a ver que pasa..la App, me advierte cada vez que la abro:

Error: Please chec the following:
1. OVMS Server address y 2. Your vehicle ID and passwords

y ya no se cuantas veces lo he repetido tanto en la aplicación y en la web de open que ya creo que me ha tocado a mi el marron, :-[
Cobaya experimental....... el nene es el unico animal que tropieza dos y mas veces con el mismo tonique......

EdTomCat

  • Avanzado
  • ***
  • Mensajes: 187
  • Waaaaatts a fons !!!
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #43 en: 28 de Marzo de 2014, 09:19:31 »
Juanma, el cable OBDII debe ser hacia la izquierda porque en la guantera se dispone de mas espacio hacia ese lado que hacia la derecha.

Suerte !
Waaaaatts a fons !!!

Juanma

  • Novatillo
  • *
  • Mensajes: 31
    • Ver Perfil
Re:Tutorial de instalación y configuración módulo OVMS
« Respuesta #44 en: 28 de Marzo de 2014, 09:59:05 »
Muchas gracias .....resueltas las dudas para realizar el pedido....... ;D